交易系统LevelII行情香港节点用户接入方案v1.4

指南下载链接 

交易系统LevelII行情香港节点用户接入方案v1.4.docx
75.0 KB

 指南正文内容 

一、交易系统LevelII行情香港节点简介

交易系统LevelII行情(以下简称“L2行情”)网络,即采用独立的专线组网的L2行情接入网。
其承载L2行情流量,包括行情快照与逐笔行情。在内地市场,L2行情用户只能选择托管局域线路接入。
为充分发挥我所证券通信基础设施完备、功能齐全、技术先进等优势,便利境外投资者投资深市和推动深港共同市场的建设,我所建设了L2行情香港节点。
境外用户可根据实际情况选择采用广域方式或局域方式接入香港节点。

二、L2行情香港节点网络接入方案

2.1局域方式接入方案

深交所L2行情香港节点,租用了HKT将军澳机房的机柜放置接入设备。
境外用户如选择局域接入,也可租用HKT将军澳机房的机柜,并通过HKT将军澳机房跳楼内局域线接入深交所L2行情设备。

2.2广域方式接入方案

境外用户也可申请广域专线接入深交所L2行情香港节点,带宽建议50Mbps,用户可根据实测情况自行选择。

2.3 接入冗余方案

考虑到单条专线接入存在中断影响业务的可能,对整体接入方案
建议如下:
●推荐:用户申请两条50M本地线(或两条托管专线)接入HKT将军澳机房收L2行情,申请一条6M本地线接入WTT柴湾机房收L1行情做备份;
●可选:用户申请一条50M本地线(或一条托管专线),申请一条6M本地线接入WTT柴湾机房收L1行情做备份;
●可选:用户只申请两条50M本地线(或两条托管专线)接入HKT将军澳机房收L2行情互为备份;此种方式当发生HKT将军澳中心节点级故障时,将没有L1行情作为备份;
●不建议:用户只申请单条50M本地线(或单条托管专线)接入HKT将军澳机房收L2行情,没有任何备份的接入方式,此种方式的业务可用性为99.6%;专线中断只能耐心等待运营商排查故障。
以用户申请两条50M本地线(或两条托管专线)接入HKT将军澳机房为例:
目前我司在HKT将军澳机房有J13、J14两个机柜,接入J13机柜可以接收到南方中心L2行情,接入J14机柜可以接收到福田中心L2行情,南方中心及福田中心是深交所的双活中心。
用户收到两路行情后,根据行情软件的配置,可选择一路作为主行情,另一路作为备行情,当主行情发生故障时,自动切换到备路行情上。

2.4接入节点与用户接入方式

用户接入点信息与初始带宽如表1。
用户接入具有以下7种组合方式,见表2:

三、用户接入技术规范

3.1用户技术要求

3.1.1线路接入类型
用户通过专线接入L2行情网及L1行情网(备份),专线类型为MSTP。
在接入该类型线路时,用户的路由设备需具备局域口(LAN口)。
3.1.2 线路检测功能
为实现网络故障的快速切换,用户须在路由设备上启用和配置BFD(双向转发检测)功能,检测网络的连通性。
3.1.3路由
3.1.3.1单播路由与辅助特性
用户接入L2行情网及L1行情网(备份)的单播路由协议均采用BGP动态路由。每个用户一个AS自治域。
由于L2行情网及L1行情网物理隔离,如用户接入L1行情网做备份,分配的IP地址及AS自治域将不同。
3.1.3.2组播路由与辅助特性
用户接入网络的组播路由协议采用PIM组播路由协议,每个用户每条线路均需要配置为sparse-mode(稀疏模式)。
组播发送采用PIM-SSM模式,因此用户的路由器、交换机至主机的操作系统均需要支持并且配置IGMPv3版本,并在网络设备上开启SSM特性。
组播流将由骨干设备推送到用户设备上,原则上用户不需要与骨干设备建立PIM邻居关系。
技术要求汇总如表4所示。
3.1.4安全
用户接入L2行情网及L1行情网(备份),应依据《证券期货业信息系统安全等级保护基本要求》中G3级别的要求,使用符合标准的路由设备安全接入,并做好网络访问控制和入侵防护工作。

3.2用户配置指引

以某用户申请两条专线接入L2行情香港节点为例:(接入L1行情网有另外的文档补充)
3.2.1 IP地址信息
3.2.2 BGP AS号
3.2.3主站服务IP
3.2.4组播组/源
注:一个网关实例只能通过L2-1行情服务组播地址列表或L2-2行情服务组播地址列表中的地址接收行情数据,不能混用。

附件 用户接入设备参考配置

IP地址、AS号、AS密码、端口号等以实际分配为准)
以连接HKT节点主用线路路由器为例,按照接入用户技术要求,建议的参考配置示例如下:

一、接入路由器接口配置

Juniper设备:
set interfaces ge-1/0/0 unit 0 family inet address 10.219.1.1/27 //用户内部接口IP地址
set interfaces ge-1/0/1 unit 0 family inet address 10.220.1.2/30 //与深交所互联接口IP
Cisco设备:
interface FastEthernet0/1
 ip address 10.220.1.2 255.255.255.252          //与深交所互联接口IP
 bfd interval 500 min_rx 500 multipler 3     //端口启用bfd
interface FastEthernet0/0
 ip address 10.219.1.1 255.255.255.224   //用户内部接口IP

二、接入路由器单播路由配置

BGP配置
Juniper设备:
set routing-options router-id 100.1.1.1 //router-id
set routing-options autonomous-system 64515 //AS号
set protocols bgp group EBGP type external //建立EBGP邻居
set protocols bgp group EBGP peer-as 43101 //对端as号
set protocols bgp group EBGP neighbor 10.220.1.1 //建立与BGP的邻居
set protocols bgp group EBGP export internal-to-bgp //发布用户地址路由进BGP
set protocols bgp group EBGP bfd-liveness-detection minimum-interval 500 //启用BGP的BFD功能
set protocols bgp group EBGP bfd-liveness-detection multiplier 3 //启用BGP的BFD功能
set routing-options static route 0.0.0.0/0 next-hop 10.219.1.2 //假设用户下联设备接口IP为10.219.1.2
set policy-options policy-statement internal-to-bgp from route-filter 10.219.1.0/27 exact //匹配用户路由
set policy-options policy-statement internal-to-bgp then accept //匹配用户路由
Cisco设备:
Router bgp  64515              //分配给用户的AS号码
Bgp router-id X.X.X.X          //ROUTER ID
Neighbor  10.220.1.1  remote-as 43101          //建立BGP邻居
Neighbor 10.220.1.1 fail-over bfd                //bgp基于bfd切换
Network  10.219.1.0 mask 255.255.255.224    //宣告用户可用地址段路由
No auto-summary                 //关闭自动汇总
Ip route 0.0.0.0 0.0.0.0 10.219.1.2  ////假设下联设备接口IP为10.229.1.2

三、接入路由器组播路由配置

PIM及IGMP的配置
Juniper设备:
set protocols igmp interface ge-1/0/0.0 version 3 //内网接口使用IGMPV3
set protocols pim interface ge-1/0/0.0 mode sparse //内网接口使用PIM SM
set protocols pim interface ge-1/0/1.0 mode sparse //广域网接口使用PIM SM
Cisco设备:
Ip pim ssm default
interface FastEthernet0/0
  ip address 10.219.1.1 255.255.255.224
ip igmp version 3                                                       //使用IGMPV3
interface FastEthernet0/1
ip address 10.220.1.2 255.255.255.252
 ip pim sparse-mode                                              //启用PIM
end
连接HKT节点备用线路路由器配置,可参照以上配置自行修改。
0 0